Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

onCourse 2.1.5

edited September 2014 in onCourse releases
This is an important bug fix release for all users of onCourse 2.1 and higher.

The major fix in this version can prevent duplicate emails being sent under some conditions and so it is highly recommended that all users running 2.1 and above upgrade as soon as possible.


  • i have downloaded and installed the new version of the Server & client. I now cannot access the new server version. I get an error message that the data file cannot be found. The message includes the path to the existing data file. It is the correct path.
    Any ideas.
  • Try holding down SHIFT when you start the server and it will prompt you to find the data file again. Perhaps you have the path slightly wrong or one level too deep.
  • I have also attempted to install the new version and got the same results, the error message is as follows:
    ish onCourse Server failed to start
    The database connection cannot be established: failed to initialise database, provided uri=file (our onCourse.iocdata file location) Please check server log for details
    Have tried to completely remove and start again, still get the same results, so am stuck, would appreciate any further ideas.
  • Even though this should already be fixed in 2.1.5, could you please try moving the data file to a location on disk without a space. eg. C:\onCourse\
  • Hi! I'm using a Mac and have the same problem with this version. I cannot use the database anymore. Shift doesn't work and even if I delete the iocdata-file, there is no selection window like in the previous 2.1.1 version, only this error:
    I also erased the spaces in the path, but it makes no difference, because I can't select the file.
    Please help, thanks
    Michael from Salzburg
  • I have tried the fix you suggested on June 15; with no success.
    I have even taken all files from onCourse off the computer and parked them on another computer to try a whole new installation. I get the same error message as those shown above.
    I have checked to see if all files have been removed via search. I can't get rid of the alias of the files that I have deleted.
  • When Ari mentions to hold down shift, that is actually tap shift while the splash screen is displayed.

    What operating system (Windows, Mac) and version of that operating system are you using?

    In 2.1.1 to 2.1.2 for both windows and mac we experienced some path and data file location problems but this is resolved. Please ensure you are using 2.1.5.

    I am unsure to what you mean by "I can't get rid of the alias of the files that I have deleted." An alias or shortcut should be easily deleted.
  • edited June 2011
    Arghhh! ***bites on knuckles*** I am having the same problems as everyone else... I have deleted my data file (kept a back up copy remotely of course)... I have uninstalled and re-installed from the beginning and somehow it still remembers where my original data file was stored and won't allow me to commence a new file (which is ultimately what I need to do - beofre my records get too big).

    this is the error message I get:
    20 Jun 2011 12:12:17,413 WARN (ish.oncourse.server.AngelServer::216) - onCourse server (build 2.1.5) starting...
    20 Jun 2011 12:12:22,031 WARN (ish.oncourse.server.AngelServer::233) - onCourse build : 2.1.5
    20 Jun 2011 12:12:22,125 WARN (ish.oncourse.server.db.DatabaseUtils:formatURI:99) - uriString: file:/C:/Users/BlackSwan/ [I have removed the pathway details for this post] /onCourse.iocdata
    20 Jun 2011 12:12:22,125 WARN (ish.oncourse.server.AngelServer::286) - failed to read the database URI

    I love using this software - but now I am a little frustrated and running behind schedule now... ***on knees*** please help :-)

    Have tried holding down shift key and it does allow me to choose a new/exisiting/sample file, however nothing more happens, and when I open the client application is says:
    "The server and client versions are incompatible. The client is a more recent build." and yet they were both downloaded from the site - server first, and then client next - both 2.1.5 versions.... I have attempted a further download of the service applicaiton - all to no avail. It has to be me - not being computer/database savvy?
  • I am guessing that what you've done is installed the Service version of the application, started it running and that it is still running as an older version in the background. Make sure you don't have the WindowsService.exe installed at all. Then make sure it isn't running either (services control panel in Windows): restart your computer to make sure.

    Now make sure you have the correct version of onCourse Server up and running (look in the splash screen for the version). Then the client.
  • Thanks Ari

    I have uninstalled all versions of the software and data files from my system. Closed the system down, reinstalled the new version 2.1.5 of both server and client - (and yes they are both the current build and I do not have windowsservice.exe installed that I can find nor is it running). Started the server - then started the client - splash both same version - and still it says at log in that the server is not compatible. Any suggestions? I have reverted back to a much earlier version of onCourse on a different computer - and it seems to be working fine - these computers are not networked, so there would be no interference. Is it possible that there is a hidden file that doesn't uninstall that could be the problem?

    I am at a total loss as to why this wont work, all assistance is welcomed...


    Roberta (BlackSwan)
  • The Windows service is called onCourseService.exe, so search for that name. Also try Start -> Control panels -> Administrative tools. Then click on "Services". That's where you will find installed services.

    And of course look to see which server the client is connecting to. It could be any machine on your network. You can see the IP address in the advanced options in the login dialog.

    It will be there somewhere!
  • Hi Ari,
    I have tried to follow all of your instructions here, and I am still running into a brick wall, the only thing I noticed is when I installed and removed the double // from the intended path name and it started installing, that there seemed to be a // in there again?? Could this be still an issue?
    Have searched everywhere for onCourseService.exe, definitely not under services...
  • I don't believe that // is an issue in the path. Your problem is elsewhere. What IP address is the client trying to connect to?
  • I have followed your instructions too, and definately do not have onCourseService.ece installed anywhere on my computer. My computer is not networked either, so it is not accessing that file from anywhere else.

    I have been successful in reloading 2.1.5 after deleting everything - however I am not able to access my existing database. If I open the server application (and don't hold down the shift key) the server opens as it should and I am able to open the onCourse client application successfully - but will need to re-enter ALL my data. If I open the server application and hold down the shift key in order to access the existing database - the server application does nothing - it just sits there inactive...

    It seems to me that a file is missing or not loaded correctly - :-?
  • Hi Ari,
    I don't get to trying to open the client, as the server opening fails about 5.08Mb as detailed before.
    I have tried deleting everything several times and starting again, with the same result. :-?
  • My response was to BlackSwan who was having trouble getting the client connecting to the server with the right version. Your problem is a different one and all about the path to the data file.

    On thing we've recently seen a few times was that people on older versions of onCourse would get their data path confused and save the onCourse.iocdata inside another onCourse.iocdata folder. If that is the case for you, try to take the inside folder out and put it in another location then try to open that. 2.1.5 has a few more checks to avoid you putting data folders inside each other like that.
  • Hi,
    I have followed all of the comments with interest. I have tried each of the suggestions. I have today completely removed all files associated with OnCourse from my system and tried to reload. I have downloaded the 2.1.5a version of Server. I have followed the instruction for downloading and installation. When I try to open the server, the alias in Applications is not linked to the Server file.
    Can you help?
  • The error message I get when trying to open the application is: The alias “onCourse Server” can’t be opened because the original item can’t be found. It appears the disk image is not opening correctly.
  • Hi Warren,

    Are you using OS X? If so, please follow these steps to open the Server.

    1. Run the terminal
    2. Type "open" and then a space
    2. drag the application into the terminal window
    3. hit return

    Unfortunately there is a known OS X issue that sometimes stops the onCourse application from mounting correctly. This will allow you to run the application successfully.
  • Thanks Natalie, that worked to allow me to open the file. I am using Mac OS X Version 10.6.8
    I am now back to my original issue. I am getting the same error message:
    " ish onCourse Server failed to start.
    The database connection cannot be established: No suitable driver found for jdbc:derby:/Applications/file:/Volumes/Data/Whole Business/Management/onCourse.iocdata/onCourse
    Please check server log for details:"
  • OK, so the path to your data file is wrong. We have spent a bit of effort for the next 2.1.6 release to make the user interface clearer. In the mean time you need to use the 'press shift while starting' trick to get the file selection dialog and then pick a location of your data file.

    If that doesn't work, paste here the relevant bit of the server log file which is created when you start up the server (that is, delete the log, start the server, choose the data file, hit the error and then see what is in the log).
  • Thanks Ari,
    I have now created a new client file. I have followed both your instructions and those of Natalie. I look forward to the next release to be able to operate the application in a normal manner.
  • Version 2.1.6 solved the problem! Thank you!
Sign In or Register to comment.