Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problem when saving enrolment

Hi Ari and team,

We seem to be getting this error when completing the "Quick enrol" form... "There was an unexpected problem when saving the enrolment, the status of the enrolment and payment cannot be verified, please do it manually."

The log says:

30 Jan 2017 14:23:48,843 [pool-15-thread-2] ERROR (ish.oncourse.qe.main.actions.ActionSaveQE:commitChanges:114) - There was a problem when saving the enrolment.

org.apache.cayenne.CayenneRuntimeException: [v.4.0.M3.2 May 26 2016 09:10:02] Exception while sending message
at ish.oncourse.ISHHttpROPConnector.sendMessage(
at ish.oncourse.IshProxyRemoteService.processMessage(
at org.apache.cayenne.rop.HttpClientConnection.doSendMessage(
at org.apache.cayenne.remote.BaseConnection.sendMessage(
at org.apache.cayenne.remote.ClientChannel.send(
at org.apache.cayenne.remote.ClientChannel.onSync(
at org.apache.cayenne.CayenneContext.doCommitChanges(
at org.apache.cayenne.CayenneContext.commitChanges(
at ish.oncourse.cayenne.CayenneContext.commitChanges(
at ish.oncourse.qe.main.actions.ActionSaveQE.commitChanges(
at ish.oncourse.qe.main.actions.ActionSaveQE.savePayment(
at ish.oncourse.qe.main.actions.ActionSaveQE.performAction(
at ish.oncourse.qe.main.actions.AbstractAction.perform(
at ish.oncourse.qe.main.QEMainController$
at ish.oncourse.qe.main.QEMainController$
at Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)
Caused by: Did not receive successful HTTP response: status code = 500, status message = [null]
at ish.oncourse.ISHHttpROPConnector.sendMessage(
... 18 more

Can you assist?


  • Which version of onCourse is this? It looks like the client is trying to connect to the server and failing.

    Is there a matching server log error?

  • Hi Ari, thanks for the reply. This is version 9.0. I checked and the server log is blank. We recreated the error a few times and the client log creates a similar entry at the same time-stamp but nothing in server log.

    We tried the different log levels like info and debug but same.

    Let me know if there's anything else we can try - we're a little behind on entering enrolments.


  • Some things to try:

    1. If the server log is completely blank, the server may have difficulty writing to the log file location. Make sure it has permissions.
    2. Can you create other records (eg. create the student outside of Quick Enrol)
    3. Does the problem happen for all enrolments into all classes and different students? We need to narrow down the cause, or see whether it is completely generic.
  • Hi Ari,

    We tried a bunch of things including your suggestions above, thank you. We ended up giving up and trying it on a different computer and everything is working perfectly.

    Thanks for your assistance anyway.

Sign In or Register to comment.