Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Cant Access ANY Data! Please help!!

edited October 2013 in onCourse discussions
I have just upgraded to the 4.1 version. I run two separate databases one for AVETMISS reporting for our RTO school and one for rolls for our Junior School. When I downloaded the Server I selected for it to use the data for the junior school and I could access that fine. I then logged out and close the client and server files. Wanting to now access the RTO file,I opened up the client server, selected existing file and the highlighted the file then all i could do is select open so my data file kept opening and not selecting the file as a whole. Then I tried importing a sample file and I was able to select the data file with no problems then a message tells me that it is an existing data file and that I need to open it via existing file. What can i do? I currently can not access any of my data files! Thanks :)


  • This is an unusual use case for us... having two data files. So you might need to go through a little hand waving to get it working the way you want. You will notice that onCourse 4.1 created a file called onCourse.cfg next to your application. This contains (amongst other things) a pointer to the path to your data.

    Now, you might like to create two copies of onCourse Server, in two different folders. Each copy will have its own onCourse.cfg file and each one will point to a different data file. To allow them both to run at once, make sure each server is running on a different port. By default that is 8181, but add something like this to the config file:


    They need to be different in the two servers so they don't run into each other. Now you can have both servers running at once and when you run the client, choose the right port to connect to each one.

Sign In or Register to comment.