Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Server Installation

Hello,

I have been using oncourse on my desktop PC. Have now got a brnad new laptop that I will use instead of the PC. Trying to install server on laptop and am getting message "The JVM could not be started. The maximum heap size (-Xmx) might be too large or firewall tool could block the execution." I have turned off the firewall and anti-virus when installing. My laptop is 2.60GHz processor, 4GB RAM, 64-bit operating system. I have updated Java to 7 and also installed the 64 bit Java. I don't know what else to try. There also seems to be something going wrong when i hit "next" button to begin the installation as the green bar only gets about half a centimeter along then the window tells me it has been installed and shortcuts created. This takes about 4 seconds! Doesn't seem right. Appreciate any help you can give me as at a loss what to do now.

Thanks
Kellie

Comments

  • Which green bar? You mean when you install Java? Perhaps you need to try uninstalling Java and installing it again from scratch.
  • Hi Ari,

    The green progress bar when installing onCourse server. It doesn't go all the way to the end. Then says it has installed. Is this right? After that I try to open onCourse and i get the JVM message. I have tried re-installing Java with no change in message.

    Thanks
  • Installing onCourse Server should only take a few seconds, that seems right. You could try upgrading to onCourse 4.1 when it comes out shortly... that has slightly lower memory requirements. Or we could host the server for you if you and your It provider continue to have difficulties with getting Java running properly.
  • Hi Ari,

    I have now successfully installed onCourse on my lap top by installing and using windows xp mode in a virtual PC for the onCourse server and client application. It is working beautifully. Not sure why my new laptop with more memory and faster processor and would not work! Something to do with the 64 Bit OS?? Unfortunatley I don't have an IT department to ask!
  • I am glad you got past the problem... I do wish Windows wasn't 10 years behind the rest of the computer industry with resolving 64bit issues (if that was indeed the problem).

    There is one thing I've just through of you can try if you want to give it a go. We have a special 64 bit version of the Windows Service application (this is just like the Windows Server, but runs without a user interface of any kind). Grab that from our download page and give it a go. You need to start it up from the "services" control panel (Start menu -> Control panels -> Administrative tools -> Services).

    Please let me know if that solves your problem so we can do more testing and see if we can reproduce your problem.
  • Thanks for your reply Ari. I have installed the onCourse Server (Service) and tried opening it through Admin tools --> services as instructed. Getting this error message "The onCourse Server64 Service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs". If you are aware of how to fix, please advise. Have tried unticking the box 'allow service to interact with desktop' in properties --> log on tab, but made no difference. Will continue to use the virtual PC for onCourse for now. Thanks Ari.
  • Unfortunately I'm out of ideas for now. We'd need to get our technical people to look at your computer. If you get to the point where you'd like a hosted onCourse or a support plan, then I'd be happy to get you in front of our technical team and do more digging. In the meantime, I'll ask our QA people to do some more testing and see if we can make something similar happen.

    If you got a server log file perhaps that might shed more light on why it didn't run.

    Cheers
    Ari
Sign In or Register to comment.