Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Help - I didn't upgrade!

I have just upgraded from an earlier version (2 something) and I am trying to open my data file but I am being told I needed to upgrade to version 3 first. What can I do?

Thank you

Comments

  • Hi Renae,

    Try running an upgrade to your datafile to the last 3.0.2 version first, then upgrade it to 4.0.1 (the one you are probably trying to run).

    If you are running Windows, you can download the 3.0.2 server from http://www.ish.com.au/s/onCourse/3.0.2/onCourseServer-installer.exe

    After the server has upgraded your datafile successfully (watch the messages in the server window - when they stop, it means its completed) you can shut it down and install and run the 4.01 server and client as previously attempted.

    If this process fails i.e. the 3.0.2 server unexpectedly shuts down during the upgrade attempt, please let me know.

    Regards,
    Natalie
  • Hi Natalie - I thought I did it all but have now upgraded to 4.0.1 and the error I get is: ish onCourse Server failed to start. The database connection cannot be established...with class loader sun.misc.Launcher$AppClassLoader@928739

    Any ideas?
  • 1. Identify whether your installation is OK by running a new database
    2. Check that it still works fine in 3.0.2
    3. Get some professional technical help to diagnose the problems. There will be a lot more information in your logs.
    4. Contact ish for a support agreement where our engineers will take your database, upgrade it and check that it is OK.

    That's pretty much the order of diagnosis at this point.
  • I have no idea what's happened but it seems to be working! Thanks Ari.
Sign In or Register to comment.